Engine 1+2 doesnt work with newer versions

All about the program
Isthor
Posts: 18
Joined: 09 Jul 2017, 22:47

16 Jun 2021, 17:14

The last version that works for me is 15.1.0.0.
With all newer versions i cant use engine 2 with LAV Filters anymore (and engine 1 - command line and user interface).

[ENGINE 1] .... An error occured during the graph building : Ausnahme von HRESULT: 0x80040273
[ENGINE 1] .... Engine 1: Can't render the file

[ENGINE 2] .... Engine 2 failed
User avatar
admin
Site Admin
Posts: 1190
Joined: 03 Jun 2014, 22:14

16 Jun 2021, 17:23

I think this is not related to VTM since Engines 1 and 2 rely on your system codecs.

Do you have a codec-pack installed?
Isthor
Posts: 18
Joined: 09 Jul 2017, 22:47

16 Jun 2021, 18:27

LAV Filters

Well it works with version 15.1.0.0 and stopped working with all newer versions, so it is related to VTM.
User avatar
admin
Site Admin
Posts: 1190
Joined: 03 Jun 2014, 22:14

16 Jun 2021, 19:00

Do you have VTM 15.0.0.0 to check right now?
Isthor
Posts: 18
Joined: 09 Jul 2017, 22:47

17 Jun 2021, 06:56

For version 15.0.0.0 i made a topic last year.
https://www.suu-design.com/forum/viewto ... f=7&t=2416

You fixed this issue (engine 2 in console) with version 15.1.0.0.

I have both 64-bit and 32-bit LAV filters 0.75 installed so applications can choose the ones they need.

I tested all combinations:

VTM 64-bit and LAV Filters 64-bit and 32-Bit: engine 1 and 2 doesnt work
VTM 32-bit and LAV Filters 64-bit and 32-Bit: everything works
VTM 64-bit and LAV Filters 64-bit: doesnt work
VTM 32-bit and LAV Filters 32-bit: everything works
VTM 64-bit and LAV Filters 32-bit: doesnt work
VTM 32-bit and LAV Filters 64-bit: doesnt work

Something is wrong with VTM and the use of LAV Filters 64-bit.

I also tested a older version of LAV Filters 0.74.1 and everything is working with VTM 16.0.0.0.
So something in LAV Filters 64-bit has changed and VTM cant use it anymore?

Here is the changelog of LAV Filters 0.75:
LAV Splitter

NEW: Support for DASH streaming
NEW: WebVTT support in Matroska/WebM
Changed: Improved Font support from Matroska files
Fixed: Large queue size limits could result in the wrong limit being applied
Fixed: Resolved a memory leak in Matroska demuxing
Fixed: Avoid selecting a stream with only a single video frame in MP4 files, which is often a cover art
Fixed: Seeking in Matroska files with only audio cue points did not function
Fixed: Seeking to the beginning of certain HLS streams did not work properly
Fixed: Duration information in Matroska files is more reliable

LAV Video

NEW: AV1 DXVA2/D3D11 hardware decoding support
NEW: ProRes 4444 XQ support
Faster: Updated dav1d decoder and improved thread configuration for significantly improved AV1 decoding speed
Fixed: Added a workaround for VP9 hardware decoding on AMD video cards
Fixed: H.264 streams exceeding the Level 5.1 DPB limit will no longer be hardware decoded
Fixed: Improved handling of missing reference frames in H.264 streams with hardware decoding
Fixed: HEVC streams encoding 8-bit video in a Main10 profile can be properly hardware decoded
Deprecated: NVIDIA CUVID and Intel QuickSync have been deprecated for future removal/replacement

LAV Audio

Fixed: Resolved an issue with glitching TrueHD bitstreaming on seamless-branching titles
Fixed: Resolved a compatibility issue with some playback applications
Deprecated: Support for the binary DTS decoder (dtsdecoderdll.dll) has been deprecated for future removal
Is this a problem with VTM cant use LAV Filters 64-bit anymore or LAV Filters 64-bit cant work with VTM anymore?
Should i report this to the LAV Filters developer or is there something you can do?
User avatar
admin
Site Admin
Posts: 1190
Joined: 03 Jun 2014, 22:14

17 Jun 2021, 11:21

Thank you for your investigation.
Here is an idea to check: what if only the latest installed LAV filters 0.75 are in the game? I mean please try to install 32-bit version of LAV filters first. Try VTM 32-bit.
Then please try to install 64-bit version of LAV filters. Try VTM 64-bit. Then Try VTM 32-bit once again.

BTW, it is senseless to try to use VTM 64-bit with LAV 32-bit,
and VTM 32-bit with LAV 64-bit.
Isthor
Posts: 18
Joined: 09 Jul 2017, 22:47

17 Jun 2021, 12:24

admin wrote:
17 Jun 2021, 11:21
Thank you for your investigation.
Here is an idea to check: what if only the latest installed LAV filters 0.75 are in the game? I mean please try to install 32-bit version of LAV filters first. Try VTM 32-bit.
Then please try to install 64-bit version of LAV filters. Try VTM 64-bit. Then Try VTM 32-bit once again.
LAV Filters 32-bit + VTM 32-bit: OK
LAV Filters 64-bit + VTM 64-bit: ERROR
LAV Filters 64-bit/32-bit + VTM 32-bit: OK
admin wrote:
17 Jun 2021, 11:21
BTW, it is senseless to try to use VTM 64-bit with LAV 32-bit,
and VTM 32-bit with LAV 64-bit.
I know, it was for completeness.
User avatar
admin
Site Admin
Posts: 1190
Joined: 03 Jun 2014, 22:14

17 Jun 2021, 12:32

So, VTM (v16.0.0.0) 64-bit never worked with LAV filters 64-bit (v0.75).

Please check your Private Messages, I have sent you the links to VTM 15.0.0.0 to test.
Isthor
Posts: 18
Joined: 09 Jul 2017, 22:47

17 Jun 2021, 13:05

I have the 15.0.0.0 setups.

LAV Filters 32-bit + VTM 32-bit - user interface engine 1+2: OK
LAV Filters 32-bit + VTM 32-bit - console engine 1+2: ERROR

LAV Filters 64-bit + VTM 64-bit - user interface engine 1: ERROR
LAV Filters 64-bit + VTM 64-bit - user interface engine 2: OK
LAV Filters 64-bit + VTM 64-bit - console engine 1+2: ERROR

LAV Filters 64-bit/32-bit + VTM 32-bit/64-bit: same like above
User avatar
admin
Site Admin
Posts: 1190
Joined: 03 Jun 2014, 22:14

17 Jun 2021, 14:12

Ok, thx for the results.

As we remember, console version did not work in VTM 15.0.0.0, it was fixed in VTM 15.1.0.0.

From my point of view, almost nothing changes in Engines 1 and 2, I see no reason why they should stop work with LAV Filters suddenly.
Need to experiment on my end.
Please advice where to download LAV Filters you used?
Post Reply